is the upgrade required?